Jump to content
PressStart

Cigarette Lighter and Radio Problem, Need Fuse Box Picture

Recommended Posts

Hello everyone! This is my first post here and second forum to ever be a part of. So I am hoping to have success here as I am really liking my Silvia. I am having issues with the power in my radio and cigarette lighter. If I turn the radio up a little high it cuts off and turns back on but will cut off again unless I turn it down. I bought extra lighter plugs (it comes with 3 and switches to turn them on or off) and plugged the main plug into the car's plug. when I turn one on it's fine but when I turned all three they died. I checked the fuses and one was blown (I don't know what fuse it is because the kickplate with the fuse decal is missing). I replaced the 15amp one that was blown with a 20amp one and the cigarette lighter worked again! However I tested the issue again by turning on all three switches and the issue occurred again. I checked all the fuses again but this time none were blown. Now I'm at a loss. Does anyone have an idea how to tackle this issue? The current radio doesn't seem to have had a great install by the looks of it so maybe a ground or something is loose or disconnected. I have a multimeter to check any wires. I will have to try again tomorrow. I hope someone can help solve this issue. I can also provide pictures if you would like! When looking around the I did notice an unconnected terminal so maybe that can mean something. Thanks a lot again! BTW my Silvia is a 96 S14.5 in Japan if that means anything.

Share this post


Link to post
Share on other sites

Welcome! 

I dare say radio would have a bad earthing point so i would go through and clean up any connections there. 

With the cigerette lighter sockets, they are only designed to handle a certain amount of current draw. Along with the electrical fuses in the interioe fuse box they also have a thermal fuse which is actually apart of the socket itself. 

Also if you are looking for a fuse box diagram then google will have a printout or you can buy a sticker from ebay too 

Share this post


Link to post
Share on other sites

I’m going to look further into finding a bad ground or something badly wired later this week or during the weekend. Thank you

With the cigarette lighter I think the socket itself may be bad. I noticed part of it looked like it got burnt (could be the thermal fuse you mentioned). I don’t think it was that dark color before. I can upload a picture of what it looks like currently. Also I checked the wire behind the plug and there’s 12.68vdc there so it’s leading me to think the socket is the issue.

Okay I will search for the diagram some more. Thank you for the help!

2192B0C5-A935-4ACB-8799-409E4638D866.jpeg

Share this post


Link to post
Share on other sites

So I found two things. First the wire was only connecting by a single thread, second was that one of the fuses was blown. I believe the fuse was the bigger reason but I'm glad I looked at the wire as well cause it could've broke off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×