Warning: Illegal string offset 'html' in /home/nissansi/public_html/forums/cache/skin_cache/cacheid_1/skin_topic.php on line 907
Power steering issue - 02 Forester - Hardtuned.net

Jump to content


Power steering issue - 02 Forester 

  • You cannot reply to this topic
No replies to this topic

#1 adubz

  • Joined:29-September 08
  • Location:Australia SA
  • Car:s13 & Toyota Hilux

Posted 02 August 2013 - 01:10 PM

Hi all,

Im Having issues with my power steering on start up in the morning. The issue is apparent only until the engine warms. Symptoms are difficulty turning steering as if there is resistance, particularly on full lock. Turning the wheel feels notchy, then frees up after 10-20 seconds. I have watched the power steering pump with someone turning the wheel (with engine running) and it seems the pump cuts in and out momentarily (causing the notchy feeling).

Is it the pump failing? Or is the belt lacking tension/ in need of replacement? Return hose to power steering pump leaking slightly? The fluid level is fine and remaining constant.

Any help much appreciated!





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Common Links

  • About Us
  • Privacy Policy
  • User Agreement
  • Help & Support Forums
  • Advertise
  •  

    By your continued use of this site, you agree to follow all Rules & Guidelines and abide by the User Agreement outlined in our Terms & Conditions.

    Hardtuned Network is hosted by Sanity Technology

    Design, Site Management & Hotness provided by Loz.

    Big thanks to all our members and volunteers for making this network what it is today!